Related to:
History Chart, Historical graphs, Active Console, Database, graphs no working.
Problem:
- You cannot connect to the database when creating a history chart.
 
Possible Cause:
- Root Cause 1: Active Console version may be outdated or does not include the library for the particular database
 - Root Cause 2: The database is not accessible from your Active Console workstation.
 - Root Cause 3: MySQL JDBC jar file is missing. If you are using MySQL for DB logging, you need to download the MySQL from their website.
 
Possible Solution:
Solution Root Cause 1
- User can go to the Help => About menu, and scroll down to locate the Database support section. Please check that the respective database library is available.
 
- Most databases are set up to be secured and only accessible from certain hosts like the Gateway host/server. Check with your network and database team if connections can be permitted from your workstation to the database.
 
Solution Root Cause 2 -
- A quick way to check if to perform a connection test via telnet or cURL or PowerShell's Test-NetConnection from your Active Console workstation to the database's host and port.
 - Below sample commands show successful connection from a workstation to the database's host and port. 
- telnet
- 
C:\WINDOWS\system32>echo quit | telnet 192.168.101.43 3306
Welcome to Microsoft Telnet Client
Escape Character is 'CTRL+]'
C:\WINDOWS\system32> 
 - 
 - cURL
- 
C:\WINDOWS\system32>curl -v 192.168.101.43:3306
* Rebuilt URL to: 192.168.101.43:3306/
* Trying 192.168.101.43...
* TCP_NODELAY set
* Connected to 192.168.101.43 (192.168.101.43) port 3306 (#0) 
 - 
 - PowerShell Test-NetConnection
- 
PS C:\WINDOWS\system32> Test-NetConnection -ComputerName 192.168.101.43 -Port 3306
ComputerName : 192.168.101.43
RemoteAddress : 192.168.101.43
RemotePort : 3306
InterfaceAlias : Ethernet 4
SourceAddress : 192.168.200.1
TcpTestSucceeded : True 
 - 
 
 - telnet
 
Solution Root Cause 3 -
- You need to download the MySQL JDBC jar, and place it under:
...\geneos-desktop-activeconsole-6.2.0-windows-x64\jars\JDBC . Then restart Active Console afterward. 
Related Articles
- What is a History Chart and how does it work?
 - Create history charts
 - When history chart is not working
 
If Issue Persists
- Please contact with our Client Services team via the chat service box available in any of our websites or via email to support@itrsgroup.com
 - Make sure you provide to us:
- Active Console diagnostic file
 - Screenshot of your Active Console showing the error when you create a History Chart.
 - Telnet, curl, netcat test from your Active Console workstation to the database host and port.
 - Any troubleshooting step already verified from the ones described in this article.
 
 
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