Related to:
ITRS Analytics, Replicated, Embedded-Cluster, Kubernetes Off-The-Shelf (KOTS) Admin Console, SSL/TLS, and Secure communications.
Problem:
Changing the TLS certificate for ITRS Analytics through the KOTS Admin Console leads to the following errors:
1 --- iax ---
2 Error: UPGRADE FAILED: cannot patch "iax" with kind Obcerv: admission webhook "validating-
webhook.obcerv.itrsgroup.com" denied the request: Updating or upgrading the Obcerv instance
kotsadm/iax is not allowed: Obcerv licence is invalid or has expired
3
4 --- iax-app-query-service ---
5 Error: UPGRADE FAILED: pre-upgrade hooks failed: 1 error occurred:
6 * job obcerv-app-query-service-configure-platform-job failed: BackoffLimitExceeded
7
8
9 --- iax-app-webconsole ---
10 W0421 09:40:25.271861 874 warnings.go:70] spec.template.spec.containers[0].env[24]: hides
11 previous definition of "OBCERV_CA_CRT", which may be dropped when using apply
12
13 --- iax-app-entities ---
14 Error: UPGRADE FAILED: pre-upgrade hooks failed: 1 error occurred:
15 * job iax-app-entities-configure-platform-job failed: BackoffLimitExceeded
Cause:
-
Expired bootstrap license: The temporary bootstrap licence (valid for a few days) has not been replaced, which is why the KOTS Admin Console is not allowing changes to the certificate.
-
It has been observed that the ITRS Analytics' licenced component is getting the following warning messages for quite some time.
2025-04-10 12:49:36.296 [grpc-server-7200-0] WARN com.itrsgroup.obcerv.platform.service.licence.LicenceGrpcService(Component-0) - No stored licence found, using bootstrap licence
. . .
2025-04-21 10:19:53.856 [grpc-server-7200-0] WARN com.itrsgroup.obcerv.platform.service.licence.LicenceGrpcService(Component-0) - No stored licence found, using bootstrap licence
-
It has been observed that the ITRS Analytics' licenced component is getting the following warning messages for quite some time.
Solution:
- Apply a permanent ITRS Analytics license: Contact ITRS Support, request a permanent license, and follow the guide from this documentation: Upload the ITRS Analytics license.
Related articles:
- ITRS Analytics - Getting Started FAQs.
- ITRS Analytics - how to verify license entitlements and related errors.
If you need further help:
-
Please contact our support team via the chat service box on any of our websites or raise a support request.
-
Make sure you provide us with:
- Background of the issue or request.
- Use cases, requirements, business impact, etc.
- Encountered error messages.
- Log files or diagnostic files.
- Screenshots.
- And other important information relevant to your inquiry.
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