Related to:
Licence has expired, Licence limit breached, Licence expiration status unknown, license manager, licenced
Problem:
ITRS Analytics includes a temporary bootstrap licence during initial installation. Users are advised to update the license file within the grace period. This article provides the procedure to verify the ITRS Analytics licenses and related errors.
Possible Causes:
- Root Cause 1:
License key has not been applied within the grace period after initial installation. Or the license key has not been renewed before license expiry. User may see this error message on ITRS Analytics web console.
Licence has expired
- Root Cause 2:
User may have exceeded the limit of their ITRS Analytics license entitlements. User may see this error message on ITRS Analytics web console.
Licence limit for <component> breached
- Root Cause 3:
ITRS Analytics components may have encountered errors when connecting "licenced" process. User may see this error message on ITRS Analytics web console.
Licence expiration status unknown
Possible Solutions:
- Solution Root Cause 1 and 2:
1. Logon to the ITRS Analytics web console as a user with admin permissions.
2. The Admin button should appear near the bottom left of the toolbar.
3. Select the License Management tab
4. The Expiry Date and Entitlements should appear on this page.
5. If user needs changes to the license expiry or entitlements, please contact your ITRS account manager or raise a support request. Please provide the displayed instance name (which should usually be the hostname or DNS name) so we can verify or update our records.
6. When user obtains the license file, select the Upload Licence button near the top right corner to apply it.
- Solution Root Cause 3:
1. User can check if the "licenced" pod is up and running.
kubectl get deployment licenced -n kotsadm
2. Obtain the exact name of licenced pod, then retrieve the logs.
kubectl get pods -n kotsadm | grep licenced
kubectl logs licenced-<id-string> -n kotsadm
3. If the log shows errors or looks stale (the log is expected to update regularly every hour), please submit a support request providing a support bundle. User may want to restart the "licenced" or related pods using "kubectl" commands.
Related Articles:
- ITRS Analytics - Admin Settings
- ITRS Analytics - Support Bundles
If you need further help:
-
Please contact our support team via the chat service box on any of our websites or raise a support request.
-
Make sure you provide us with:
- Encountered error messages.
- Log files or diagnostic files.
- Screenshots.
- And other important information relevant to your inquiry.
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