Related to:
Processes plugin timed out, Failed to execute, plugin PROCESSES timed out, Processes plugin not working, ERROR: Failed to execute.
Problem
- The Processes plugin is showing Failed to execute .. plugin PROCESSES timed out in the NetProbe Log file and displaying TIMED OUT in the sampling status.
Possible Causes
Root Cause 1 -
RegEx mode set to default
Root Cause 2 -
Use of regular expression wildcards
Root Cause 3 -
NetProbe running out of file descriptors
Root Cause 4 -
Advanced Tab options selected including wide process support, cache wide process names, adjust for logical CPU's.
Possible Solutions
Solution Root Cause 1 - Switch the regexMode setting to PCRE. The default value of this setting is Extended which uses the POSIX extended regular expression syntax installed on the Netprobe host. The PCRE on the otherhand uses the library included in the Netprobe package. The PCRE is a more optimised option and is recommended to set.
Solution Root Cause 2 -The use of regular expression wildcards may be inefficient or return too much information. Look to use a regex test website to test and streamline the options.
Solution Root Cause 3 -Check the limits by running ulimit -a. Increase file descriptors limit if a limit is imposed.
Solution Root Cause 4 -Uncheck advanced tab options
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If Issue Persists
- Please contact with our Client Services team via the chat service box available in any of our websites or via email to support@itrsgroup.com
- Make sure you provide to us
- Please contact with our Client Services team via the chat service box available in any of our websites or via email to support@itrsgroup.com
- XML of the processes sampler
- Increase NetProbe Max Log setting - Link below
- Apply Sampling debug option - Link below
-Apply Processes plugin debug option - Screenshot below
Note - The cache and processes Modules both have * as their Setting
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